S&R: Fehler "Airpressure"  (Gelesen 16182 mal)

UweDB

  • Gast
S&R: Fehler "Airpressure"
am: 16.09.2008, 17:24:19
Hallo,

nachdem ich nun die richtige DLL am richtigen Platz (dank an Gerald) habe, kommt nun ein neues Problem:
beim Importvorgang erscheint der Laufzeitfehler "ERROR relation Airpressure does not exist"

Habe ich die Chance, die Sache doch noch zu laufen zu kriegen? Danke für die Hilfe!

Gruß,
Uwe

Wetterstationen.info Forum

S&R: Fehler "Airpressure"
« am: 16.09.2008, 17:24:19 »

gggv

  • Gast
S&R: Fehler "Airpressure"
Antwort #1 am: 16.09.2008, 20:14:06
Servus!
Nicht dass ich eine Lösung wüsste, aber schau doch mal mit pgadmin.exe (sollte irgendwo bei deiner Datenbank liegen) nach ob die Daten richtig vorhanden sind. Anleitung dazu findet du unter

http://www.wetterstationen.info/phpBB/viewtopic.php?t=14772&highlight=

Hoffe du kommst weiter!

LG
Gerald

Offline LE-Wetter

  • Allgemeiner Moderator
    • https://www.leipzig-wetter.de
  • Registriert:
    28.01.2007, 15:34:05
  • Beiträge: 3.133
  • 51°22'05" N, 12°21'52" O, 122 m ü.NN
  • Ort:
    Leipzig
S&R: Fehler "Airpressure"
Antwort #2 am: 16.09.2008, 21:01:30
@Uwe

vielleicht läßt du uns mal teilhaben, welche Daten du wohin importieren willst :confused:
Auf alle Fälle scheint ja etwas mit deinen Luftdruckdaten nicht zu stimmen.
1. Hast du Luftdruckdaten in der Datenbank Postgre?
2. Werden Sie in WP angezeigt?
3. Bei welchem Vorgang kommt die Fehlermeldung?
Liebe Grüße von LE-Wetter

WS 888, Mete-On1 und WD4000 und
alte Barometer, Blitzortung, Radioaktivität
https://www.leipzig-wetter.de
www.regionalwetter-sa.de
www.wetternetz-sachsen.de
www.wetterhistorie-leipzig.de

UweDB

  • Gast
S&R: Fehler "Airpressure"
Antwort #3 am: 16.09.2008, 21:27:19
Hallo,

zu 1. Ja
zu 2. Ja
zu 3. beim Start von S&R

Ich versuche mich als Neuling in die Webseitengestaltung bzw. der Einbindung akueller Wetterdaten. Aktuell läuft WP1.8 (ELV WS300) und
Sun&Rain 4.

Guß,
Uwe


Zitat von: "LE-Wetter"
@Uwe

vielleicht läßt du uns mal teilhaben, welche Daten du wohin importieren willst :confused:
Auf alle Fälle scheint ja etwas mit deinen Luftdruckdaten nicht zu stimmen.
1. Hast du Luftdruckdaten in der Datenbank Postgre?
2. Werden Sie in WP angezeigt?
3. Bei welchem Vorgang kommt die Fehlermeldung?

Offline leknilk0815

  • Allgemeiner Moderator
    • http://www.antonhofer.de/wetter/ws300wswin/html/custom.html
  • Registriert:
    14.06.2006, 12:06:21
  • Beiträge: 10.039
  • Ort:
    Wackersberg, 661m / NN
Re: S&R: Fehler "Airpressure"
Antwort #4 am: 16.09.2008, 21:53:33
Zitat von: "UweDB"
beim Importvorgang erscheint der Laufzeitfehler "ERROR relation Airpressure does not exist"

Was bitte ist bei S&R ein "Importvorgang"?
Ich arbeite zwar erst 2,5 Jahre damit, aber meins hat noch nix importiert...
Gruß - Toni

KS300+WS444PC (WSL/WSWIN)+Windrichtung+Sonnenschein, CCU2, KS550, KS888

Wetterstationen.info Forum

Re: S&R: Fehler "Airpressure"
« Antwort #4 am: 16.09.2008, 21:53:33 »

UweDB

  • Gast
Re: S&R: Fehler "Airpressure"
Antwort #5 am: 17.09.2008, 07:01:22
Entschuldigung, dass ich mich hier falsch ausgedrückt habe und ich Dich scheinbar damit belästigt habe...

Ich meinte eigentlich den Moment, wenn beim Start von S&R auf die Datenbank zugegriffen wird. Oder habe ich hier was falsch bezüglich der Wirkungsweise von S&R verstanden? Wenn ja, entschuldige ich mich dafür auch gleich!

Uwe




Zitat von: "leknilk0815"
Zitat von: "UweDB"
beim Importvorgang erscheint der Laufzeitfehler "ERROR relation Airpressure does not exist"

Was bitte ist bei S&R ein "Importvorgang"?
Ich arbeite zwar erst 2,5 Jahre damit, aber meins hat noch nix importiert...

Offline leknilk0815

  • Allgemeiner Moderator
    • http://www.antonhofer.de/wetter/ws300wswin/html/custom.html
  • Registriert:
    14.06.2006, 12:06:21
  • Beiträge: 10.039
  • Ort:
    Wackersberg, 661m / NN
S&R: Fehler "Airpressure"
Antwort #6 am: 17.09.2008, 18:59:23
Du hast mich nicht belästigt und entschuldigen brauchst Du Dich auch nicht, nur ist eben ein Import und ein Zugriff auf einer DB was ganz anderes, das fürht zu Missverständnissen.
So richtig helfen fürchte ich, kann ich Dir auch nicht, da dieser Fehler unbekannt ist, sowei mir bekannt.
Nachdem die Daten in WP anscheinend angezeigt werden, sollte die DB ok sein. Man könnte S&R neu draufkopieren, aber die Erfolgsaussicht ist nahe null. Irgendwie vermute ich den Fehler in der DB, wenn Du noch nicht viele Daten drauf hast, würde ich alles komplett neu installieren..
Gruß - Toni

KS300+WS444PC (WSL/WSWIN)+Windrichtung+Sonnenschein, CCU2, KS550, KS888

Offline LE-Wetter

  • Allgemeiner Moderator
    • https://www.leipzig-wetter.de
  • Registriert:
    28.01.2007, 15:34:05
  • Beiträge: 3.133
  • 51°22'05" N, 12°21'52" O, 122 m ü.NN
  • Ort:
    Leipzig
S&R: Fehler "Airpressure"
Antwort #7 am: 17.09.2008, 19:58:50
@UweDB

selbiger Tipp auch von mir. S&R komplett deinstallieren und neu installieren. Sollte dann das gleiche passieren, ist es definitiv ein Fehler in der Datenbank. Sieh vorher mal in Postgre unter Schemata Daten anzeigen ob Einträge in der Datentabelle unter Airpress vorhanden sind. Sind da fehlerhafte Einträge, dann alles neu installieren  :-(
Liebe Grüße von LE-Wetter

WS 888, Mete-On1 und WD4000 und
alte Barometer, Blitzortung, Radioaktivität
https://www.leipzig-wetter.de
www.regionalwetter-sa.de
www.wetternetz-sachsen.de
www.wetterhistorie-leipzig.de

UweDB

  • Gast
S&R: Fehler "Airpressure"
Antwort #8 am: 18.09.2008, 07:34:24
@all
Ich versuche am Wochenende nochmal alles zu reinstallieren. Vielleicht habe ich ja Glück :confused:

Ich gebe Bescheid ...

Danke und Gruß,
Uwe

Wetterstationen.info Forum

S&R: Fehler "Airpressure"
« Antwort #8 am: 18.09.2008, 07:34:24 »

Offline leknilk0815

  • Allgemeiner Moderator
    • http://www.antonhofer.de/wetter/ws300wswin/html/custom.html
  • Registriert:
    14.06.2006, 12:06:21
  • Beiträge: 10.039
  • Ort:
    Wackersberg, 661m / NN
S&R: Fehler "Airpressure"
Antwort #9 am: 18.09.2008, 07:51:24
sorry, wenn ich schon wieder korrigiere...
"reinstallieren" bedeutet meist drüberbügeln. Damit wird sich das Problem aber nicht lösen lassen. Du musst versuchen, S&R, WP und PG so sauber wie möglich runterzubekommen, idealerweise auch noch die Registry "putzen", falls Du davon eine Ahnung hast (sonst lass es lieber!)

sieh Dir mal den Beitrag von Murgwetter an:
http://www.wetterstationen.info/phpBB/viewtopic.php?t=14946&postdays=0&postorder=asc&start=15

Ich schätze, damit gehts auch ohne Neuinstall... (ein paar PG Kentnisse vorausgesetzt oder anzulesen...)
Gruß - Toni

KS300+WS444PC (WSL/WSWIN)+Windrichtung+Sonnenschein, CCU2, KS550, KS888